const regex = /^(?P<start>.*)\s(-|to)\s(?P<end>.*)$/is;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<start>.*)\\s(-|to)\\s(?P<end>.*)$', 'is')
const str = `18/03/1989 to 19/10/2000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}