const regex = /(?s)(.*VPS_CUSTOMER.*VALUES \((?:.*,){14})(.*,)((.*,)*)(.*;)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(.*VPS_CUSTOMER.*VALUES \\((?:.*,){14})(.*,)((.*,)*)(.*;)', '')
const str = `INSERT INTO table (cola, colb, colc, cold, cole, colf, colg, colg, colh, coli, colj, colk, coll, colm, coln, colo, colp, colq, colr, cols, colt, culu) VALUES (1, '2', 3, NULL, '5', 6, '7', '8', 9, NULL, NULL, 12, '13', '14', '15', '16', '17', '18', '19', 20, '21', 22');
INSERT INTO table (cola, colb, colc, cold, cole, colf, colg, colg, colh, coli, colj, colk, coll, colm, coln, colo, colp, colq, colr, cols, colt, culu) VALUES (1, '2', 3, NULL, '5', 6, '7', '8', 9, NULL, NULL, 12, '13', '14', '
15
', '16', '17', '18', '19', 20, '21', '22');`;
const subst = `\1\3\5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);