using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)\[(\d+)/(\d+)\](?:\s|$)";
string input = @"Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}