package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+)\[(\d+)/(\d+)\](?:\s|$)`)
var str = `Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}