$re = '~(\S+)\[(\d+)/(\d+)\](?:\s|$)~';
$str = 'Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);