re = /(\S+)\[(\d+)\/(\d+)\](?:\s|$)/
str = 'Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end