// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S+)\[(\d+)/(\d+)\](?:\s|$)").unwrap();
let string = "Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}