import Foundation
let pattern = #"(\S+)\[(\d+)/(\d+)\](?:\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Richard///[][][12345/678910111213141516] was murdered by Ralph[/[54321/161514131211109876]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)