re = /^([1-9]{1}|(0[0-9]|1[0-2]))\/([1-9]{1}|0[1-9]|1\d|2\d|3[01])\/\d{4}$/
str = '12/31/1999'
# Print the match result
str.match(re) do |match|
puts match.to_s
end