// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([1-9]{1}|(0[0-9]|1[0-2]))\/([1-9]{1}|0[1-9]|1\d|2\d|3[01])\/\d{4}$").unwrap();
let string = "12/31/1999";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}