$re = '/\b(?:https?:\/\/)(?:www\d?\.)?[-\w\d\/?\.=&\+]+\b/m';
$str = 'https://habibs.myportfolio.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);