import Foundation
let pattern = #"logs\\(.*?\.log)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
input {
file {
path => "C:\tools\apache-tomcat-8.0.32\logs\abcd_access_log.2016-03-15.log"
start_position => beginning
}
}
input {
file {
path => "C:\tools\apache-tomcat-8.0.32\logs\efgh_access_log.2016-02-16.log"
start_position => beginning
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)