#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<p>\K([^><]+)(?=</p>)"
Local $sString = "<p> <img src="spas01.jpg" alt="" width="630" height="480"></p>" & @CRLF & _
"<p style="text-align: right;"><a href="spas.html">Spas</a></p>" & @CRLF & _
"<p>My Site Content [...]</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")