using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>\K([^><]+)(?=</p>)";
string input = @"<p> <img src=""spas01.jpg"" alt="" width=""630"" height=""480""></p>
<p style=""text-align: right;""><a href=""spas.html"">Spas</a></p>
<p>My Site Content [...]</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}