const regex = /(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,-]+)(?:\:?)(?<option>[\w,]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\?|\\&)(?<key>[\\w]+)=(?<value>[\\w+,-]+)(?:\\:?)(?<option>[\\w,]*)', 'g')
const str = `<link href='http://fonts.googleapis.com/css?family=Open+Sans:800italic,400,300&subset=latin-ext,latin,greek' rel='stylesheet' type='text/css'>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}