using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z](?:\s\d+|\s?\w+[,.-]+)*\s[^\s]+[.\s]*$";
string input = @"I fell down the stairs on June 30th, 1962.
There are 123 boxes on up the hill, says that 612 guy.
The lazy brown fox is not a dog.
This sentence will work .
That one finally works... yay!
How do you spell-- regex?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}