const regex = /(?<minutes>[0-9]|[1-5][0-9]):(?&minutes);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<minutes>[0-9]|[1-5][0-9]):(?&minutes);', '')
const str = `42:24;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}