# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?=\b(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu})//g;t' <<< "Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: we A G R E E indeed."