use strict;
my $str = 'Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: we A G R E E indeed.';
my $regex = qr/(?:(?=\b(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";