# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=\P{L})(?=(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu}(?!\p{L}))//g;t' <<< "Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: weA É A G R E E Éindeed."