import Foundation
let pattern = #"(?:(?<=\P{L})(?=(?:\p{Lu}\h+){2}\p{Lu})|\G(?!\A))\p{Lu}\K\h+(?=\p{Lu}(?!\p{L}))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Welcome to A I: the best W O R L D!
Hi I R is the B O M B for sure: weA É A G R E E Éindeed.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)