using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".(?:src=""(http:\/\/website\.bla\.com\/Live.+?)"".+?)|Status.*\s(Sld|Rtr)";
string input = @"<div ng-class=""{
'active': active
}"" class=""item text-center ng-isolate-scope"" ng-transclude="" ng-repeat=""slide in slides"" active=""slide.active"">
<img class=""image-circle ng-scope"" ng-src=""http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg"" src=""http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg"">
</div><!-- end ngRepeat: slide in slides --><div ng-class=""{
'active': active
}"" class=""item text-center ng-isolate-scope"" ng-transclude="" ng-repeat=""slide in slides"" active=""slide.active"">
<img class=""image-circle ng-scope"" ng-src=""http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg"" src=""http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg"">
</div><!-- end ngRepeat: slide in slides --><div ng-class=""{
'active': active
}"" class=""item text-center ng-isolate-scope"" ng-transclude="" ng-repeat=""slide in slides"" active=""slide.active"">
<img class=""image-circle ng-scope"" ng-src=""http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg"" src=""http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg"">
</div><!-- end ngRepeat: slide in slides -->
</div>
<b class=""ng-binding"">Status:</b> Sld";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}