import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".(?:src=\"(http:\\/\\/website\\.bla\\.com\\/Live.+?)\".+?)|Status.*\\s(Sld|Rtr)";
final String string = "<div ng-class=\"{\n"
+ " 'active': active\n"
+ " }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
+ " <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\" src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\">\n"
+ " </div><!-- end ngRepeat: slide in slides --><div ng-class=\"{\n"
+ " 'active': active\n"
+ " }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
+ " <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\" src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\">\n"
+ " </div><!-- end ngRepeat: slide in slides --><div ng-class=\"{\n"
+ " 'active': active\n"
+ " }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
+ " <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\" src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\">\n"
+ " </div><!-- end ngRepeat: slide in slides -->\n"
+ " </div>\n"
+ "<b class=\"ng-binding\">Status:</b> Sld";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}