# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".(?:src=\"(http:\/\/website\.bla\.com\/Live.+?)\".+?)|Status.*\s(Sld|Rtr)"
test_str = ("<div ng-class=\"{\n"
" 'active': active\n"
" }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
" <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\" src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\">\n"
" </div><!-- end ngRepeat: slide in slides --><div ng-class=\"{\n"
" 'active': active\n"
" }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
" <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\" src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\">\n"
" </div><!-- end ngRepeat: slide in slides --><div ng-class=\"{\n"
" 'active': active\n"
" }\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">\n"
" <img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\" src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\">\n"
" </div><!-- end ngRepeat: slide in slides -->\n"
" </div>\n"
"<b class=\"ng-binding\">Status:</b> Sld")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.