#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:/(?:[0-9A-Za-z-]+/)*[&?=0-9A-Za-z-]*)?$"
Local $sString = "SHOULD MATCH" & @CRLF & _
"/" & @CRLF & _
"/section" & @CRLF & _
"/section/article-1" & @CRLF & _
"/section/article-1/" & @CRLF & _
"/section/article-1?x=y&hello=world" & @CRLF & _
"" & @CRLF & _
"SHOULD NOT MATCH" & @CRLF & _
"section/article-1" & @CRLF & _
"/section/!$*" & @CRLF & _
"/x(1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")