re = /^(?:\/(?:[0-9A-Za-z-]+\/)*[&?=0-9A-Za-z-]*)?$/m
str = 'SHOULD MATCH
/
/section
/section/article-1
/section/article-1/
/section/article-1?x=y&hello=world
SHOULD NOT MATCH
section/article-1
/section/!$*
/x(1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end