$re = '/(?:<[^\/]*?.*?<\/.*?>)|(:\/)/';
$str = 'not feeling well today :/ check out this link <a href="http://example.com">http://example.com</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);