import Foundation
let pattern = #".*\\24(.*:.*?)\\24"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"\24s904dS\24sr4d2\24x\\y\\12z:234F\\3dRl\24o980\24foo:bar\24abcd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)