re = /(?:[^`!@#$%^&*\-_=+'\/.,]*[`!@#$%^&*\-_=+'\/.,]){2}/
str = 'text 22 # and one more /'
# Print the match result
str.match(re) do |match|
puts match.to_s
end