#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<moolinkx pageid="([^"]+)">([^<]+)<\/moolinkx>"
Local $sString = "<p>blabalblahhh <moolinkx pageid="121">text to click</moolinkx> blablabah.</p>" & @CRLF & _
"<p>Another <moolinkx pageid="128">text to clickclick</moolinkx> again blablablah.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")