using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<moolinkx pageid=""([^""]+)"">([^<]+)<\/moolinkx>";
string input = @"<p>blabalblahhh <moolinkx pageid=""121"">text to click</moolinkx> blablabah.</p>
<p>Another <moolinkx pageid=""128"">text to clickclick</moolinkx> again blablablah.</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}