Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[0-9]{0,9}(-[0-9]{0,4})?$
/
gm
Input 1
1
New
NoBcAl A - 9- -9 - 9- 99- 999- 9999- 99999- 999999- 9999999- 99999999- 999999999 9999999999 9999999999- 9999999999-9 999999999- 999999999-9 999999999-99 999999999-999 999999999-9999 999999999--9999 999999999-99999 999999999-999999 999999999-999999- -9 -99 -999 -9999 -99999 9-9