# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/270?(\d{9})/0\1/g;t' <<< "0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789"