using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"270?(\d{9})";
string substitution = @"0\1";
string input = @"0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}