$re = '/270?(\d{9})/';
$str = '0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
27123456789
270123456789';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;