# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^ ]*) ([^ ]*) ([^ ]*) (\[(.*)\]) (\"(.*)\") ([0-9]*) ([0-9]*) (\"(.*)\") (\"(.*))"
test_str = "70.39.184.135 - - [10/Dec/2014:19:20:59 +0530] \"GET /wp-content/themes/wplms/js/bootstrap.min.js?ver=3.8.5 HTTP/1.1\" 200 29074 \"http://etlhive.com/redhat-linux-training-in-pune/\" \"UCWEB/2.0 (Symbian; U; S60 V3; en-US; NokiaC5-00.2) U2/1.0.0 UCBrowser/9.2.0.336 U2/1.0.0 Mobile\""
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.