# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\\/ul\>)<\\/ul>/[list]$2[\/list]/gi;t' <<< "<ul class=\"bbc\"><li>mierda</li></ul>
<ul class=\"bbc bbcol decimal\">
<li>mierda</li>
<li>mierda</li>
</ul>
<ul class=\"bbc\"><li>mierda</li></ul>"