#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<ul.*?class=([\'\"])(?:s|bbc)\1[^>]*>(.*?)(?=\<\/ul\>)<\/ul>"
Local $sString = "<ul class="bbc"><li>mierda</li></ul>" & @CRLF & _
"" & @CRLF & _
"<ul class="bbc bbcol decimal">" & @CRLF & _
"<li>mierda</li>" & @CRLF & _
"<li>mierda</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<ul class="bbc"><li>mierda</li></ul>"
Local $sSubst = "[list]$2[/list]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)