package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<name>\w+)\s*(\((?<e>([^()]*+|(?2))+)\))`)
var str = `foo(() ((hello) world))
bar (hello world!)
baz((()))
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}