#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)[x+-]\s*(?:may15|may)\K|(?:may15|may)\s*[x+-]\K|(?:may15|may)"
Local $sString = "x May15 > WRONG" & @CRLF & _
"- May15 > WRONG" & @CRLF & _
"+ May15 > WRONG" & @CRLF & _
"xMay15 > WRONG" & @CRLF & _
"-May15 > WRONG" & @CRLF & _
"+May15 > WRONG" & @CRLF & _
"May15 > TRUE" & @CRLF & _
"May15, > TRUE" & @CRLF & _
"May15 + > FALSE" & @CRLF & _
"May15 x > FALSE" & @CRLF & _
"" & @CRLF & _
"TRADED; Mar15 x May15, 5 MW Base 121,50 TL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")