import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[^_]*_){5}[^_]*).*$";
final String string = "HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html\n"
+ "HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf\n"
+ "HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}