re = /^\s*\b\d{1,2}\b(\s*\,?\s*\b\d{1,2}\b)*\s*$/m
str = '11111111
1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
1,11,14,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end