re = /\s*(\d{1,5})?\s*(?:<(?<pri>\d{1,3})>)/im
str = '23123<123>
123 <1>
123 <123>
123<12>
<123>
<1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end