$re = '/:y\b/m';
$str = 'Good one :y. Keep going :y2
';
$subst = "a";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;