import Foundation
let pattern = #":y\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Good one :y. Keep going :y2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)