re = /(?<=Fields\(")(\w+?)(?="\)\.Value =)/m
str = 'Fields("lmlEmployeeID").Value = oRs.Fields("lmpEmployeeID").Value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end