// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*eval\(base64_decode\([^\>]*?\)\);").unwrap();
let string = " eval(base64_decode(\"sdsadhsjdbsajdjsadksadsdsadsahsadjsabjdhbasjbdssbsdsansasadsadsadsadsa
dsadsadasddsadsdsasdsdasdssadsdhssbdjdsdsadjsaadksajdk\"
));
));";
let substitution = "?\\>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}