#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bMac\b.*\bExchangeWebServices\b"
Local $sString = "This expression can only match a string containing Mac and ExchangeWebServices but not just Mac." & @CRLF & _
"This expression should not match Macintosh and ExchangeWebServices!" & @CRLF & _
"Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);" & @CRLF & _
"Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);" & @CRLF & _
"Mac OS X/10.5; ExchangeWebServices/6.0 (243);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")