package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bMac\b.*\bExchangeWebServices\b`)
var str = `This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}