import Foundation
let pattern = #"\bMac\b.*\bExchangeWebServices\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This expression can only match a string containing Mac and ExchangeWebServices but not just Mac.
This expression should not match Macintosh and ExchangeWebServices!
Mac OS X/10.11.5 (15F34); ExchangeWebServices/6.0 (243);
Mac iOS/10.11.5; ExchangeWebServices/6.0 (243);
Mac OS X/10.5; ExchangeWebServices/6.0 (243);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)